re = /(AAA|BBB|CCC|DDD)\((([^()]*|\([^()]*\))*)\)/
str = 'one two 12AAA(CCC(C1_1);A1_1;DDD(145))dfg
dfgdfgdfg,BBB(B1_1; CCC(C1_1); B1_2) sfsgndf
dfgnhjdfglkjdfg DDD(D1_1)
CCC()
one two 12AAA(CCC(C1_1; DDD(D1_1));A1_1)dfg '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end