using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:((?:\.|^).)|.)(?=.*@)";
string substitution = @"$1*";
string input = @"captain.am-e-r-ica@email.com
my-cutie.pie+here@email.com
tom.cat@email.com
cutie.pie@email.com
captain.america@email.com";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}