import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:((?:\\.|^).)|.)(?=.*@)";
final String string = "captain.am-e-r-ica@email.com\n"
+ "my-cutie.pie+here@email.com\n"
+ "tom.cat@email.com\n"
+ "cutie.pie@email.com\n"
+ "captain.america@email.com";
final String subst = "$1*";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}