package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{2}/\d{2}/\d{4}), (\d{2}:\d{2}) - ([^:]+):\s*(.+)`)
var str = `04/10/2020, 12:34 - Sender: Alright. This is the "message", with multiple de-limiters.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}