$re = '/^(\d{2}/\d{2}/\d{4}), (\d{2}:\d{2}) - ([^:]+):\s*(.+)/m';
$str = '04/10/2020, 12:34 - Sender: Alright. This is the "message", with multiple de-limiters.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);