const regex = new RegExp('^(\\d{2}/\\d{2}/\\d{4}), (\\d{2}:\\d{2}) - ([^:]+):\\s*(.+)', 'gm')
const str = `04/10/2020, 12:34 - Sender: Alright. This is the "message", with multiple de-limiters.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}