import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{2}/\\d{2}/\\d{4}), (\\d{2}:\\d{2}) - ([^:]+):\\s*(.+)";
final String string = "04/10/2020, 12:34 - Sender: Alright. This is the \"message\", with multiple de-limiters.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}