re = /^(\d{2}\/\d{2}\/\d{4}), (\d{2}:\d{2}) - ([^:]+):\s*(.+)/m
str = '04/10/2020, 12:34 - Sender: Alright. This is the "message", with multiple de-limiters.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end