#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(.*)[<]+(?'start'.*)[>]+(.*)[<]+[\/]+(\k'start')[>]+(.*)$|^(.*)[<]+(.*)|[\/]+[>]+(.*)$"
Local $sString = "https://009099mbaf.papersave.com:448/PaperSave.WebModule/logon.aspx?ReturnUrl=/PaperSave.WebModule/DocumentExplorer.aspx?ParentID="><img src=aaa onerror=alert(10484773)>&TransactionType=Contract&Module=Contract+Administration&HostApplication=Dynamics+GP&Company=Fabrikam,+Inc.&Action=CopyLink&ParentID="><img src=aaa onerror=alert(10484773)>&TransactionType=Contract&Module=Contract+Administration&HostApplication=Dynamics+GP&Company=Fabrikam,+Inc.&Action=CopyLink#"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")