// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(.*)[<]+(?'start'.*)[>]+(.*)[<]+[\/]+(\k'start')[>]+(.*)$|^(.*)[<]+(.*)|[\/]+[>]+(.*)$").unwrap();
let string = "https://009099mbaf.papersave.com:448/PaperSave.WebModule/logon.aspx?ReturnUrl=/PaperSave.WebModule/DocumentExplorer.aspx?ParentID=\"><img src=aaa onerror=alert(10484773)>&TransactionType=Contract&Module=Contract+Administration&HostApplication=Dynamics+GP&Company=Fabrikam,+Inc.&Action=CopyLink&ParentID=\"><img src=aaa onerror=alert(10484773)>&TransactionType=Contract&Module=Contract+Administration&HostApplication=Dynamics+GP&Company=Fabrikam,+Inc.&Action=CopyLink#";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}