const regex = /^(.*)[<]+(?'start'.*)[>]+(.*)[<]+[\/]+(\k'start')[>]+(.*)$|^(.*)[<]+(.*)|[\/]+[>]+(.*)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*)[<]+(?\'start\'.*)[>]+(.*)[<]+[\\\/]+(\\k\'start\')[>]+(.*)$|^(.*)[<]+(.*)|[\\\/]+[>]+(.*)$', 'g')
const str = `https://009099mbaf.papersave.com:448/PaperSave.WebModule/logon.aspx?ReturnUrl=/PaperSave.WebModule/DocumentExplorer.aspx?ParentID="><img src=aaa onerror=alert(10484773)>&TransactionType=Contract&Module=Contract+Administration&HostApplication=Dynamics+GP&Company=Fabrikam,+Inc.&Action=CopyLink&ParentID="><img src=aaa onerror=alert(10484773)>&TransactionType=Contract&Module=Contract+Administration&HostApplication=Dynamics+GP&Company=Fabrikam,+Inc.&Action=CopyLink#`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}