use strict;
my $str = 'https://009099mbaf.papersave.com:448/PaperSave.WebModule/logon.aspx?ReturnUrl=/PaperSave.WebModule/DocumentExplorer.aspx?ParentID="><img src=aaa onerror=alert(10484773)>&TransactionType=Contract&Module=Contract+Administration&HostApplication=Dynamics+GP&Company=Fabrikam,+Inc.&Action=CopyLink&ParentID="><img src=aaa onerror=alert(10484773)>&TransactionType=Contract&Module=Contract+Administration&HostApplication=Dynamics+GP&Company=Fabrikam,+Inc.&Action=CopyLink#';
my $regex = qr/^(.*)[<]+(?'start'.*)[>]+(.*)[<]+[\/]+(\k'start')[>]+(.*)$|^(.*)[<]+(.*)|[\/]+[>]+(.*)$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}