use strict;
my $str = '\'click .buttonaudio\': function(evt) {
$.k2l.m2a24_6.sound.src = $(evt.currentTarget).attr(\'data-audiosrc\');
$.k2l.m2a24_6.sound.play();
},';
my $regex = qr/('click \.buttonaudio': function\(evt\) {
(\$\.k2l\.m.{1,2}a.{1,2}_{0,1}.{0,2}\.sound)\.src = \$\(evt\.currentTarget\)\.attr\('data-audiosrc'\);)
(\$\.k2l\.m.{1,2}a.{1,2}_{0,1}.{0,2}\.sound\.play\(\);
},)/p;
my $subst = '\\1\\n\\t\\taddSpinner(\\2,$(evt.currentTarget);\\n\\t\\t\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";