// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"('click \.buttonaudio': function\(evt\) {
(\$\.k2l\.m.{1,2}a.{1,2}_{0,1}.{0,2}\.sound)\.src = \$\(evt\.currentTarget\)\.attr\('data-audiosrc'\);)
(\$\.k2l\.m.{1,2}a.{1,2}_{0,1}.{0,2}\.sound\.play\(\);
},)").unwrap();
let string = "'click .buttonaudio': function(evt) {
$.k2l.m2a24_6.sound.src = $(evt.currentTarget).attr('data-audiosrc');
$.k2l.m2a24_6.sound.play();
},";
let substitution = "\\1\\n\\t\\taddSpinner(\\2,$(evt.currentTarget);\\n\\t\\t\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}