#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*(?:(?:,\s*)?\band\s+|,\s*)"
Local $sString = "Some words" & @CRLF & _
"Some words and some other words" & @CRLF & _
"Some words, more words and some other words" & @CRLF & _
"Some words, more words, and some other words" & @CRLF & _
"" & @CRLF & _
"Some words , words" & @CRLF & _
"Some band here, more text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")