re = /\s*(?:(?:,\s*)?\band\s+|,\s*)/m
str = 'Some words
Some words and some other words
Some words, more words and some other words
Some words, more words, and some other words
Some words , words
Some band here, more text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end