using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(?:(?:,\s*)?\band\s+|,\s*)";
string input = @"Some words
Some words and some other words
Some words, more words and some other words
Some words, more words, and some other words
Some words , words
Some band here, more text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}