package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*(?:(?:,\s*)?\band\s+|,\s*)`)
var str = `Some words
Some words and some other words
Some words, more words and some other words
Some words, more words, and some other words
Some words , words
Some band here, more text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}