const regex = new RegExp('\\s*(?:(?:,\\s*)?\\band\\s+|,\\s*)', 'gm')
const str = `Some words
Some words and some other words
Some words, more words and some other words
Some words, more words, and some other words
Some words , words
Some band here, more text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}