#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([A-Fa-f0-9]{2})([:\-\.]?)(?=[A-Fa-f0-9])"
Local $sString = "AA.BB.CC:DD:EE:FF"
Local $sSubst = "$1:"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)