import Foundation
let pattern = #"([A-Fa-f0-9]{2})([:\-\.]?)(?=[A-Fa-f0-9])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"AA.BB.CC:DD:EE:FF"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1:"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)