use strict;
my $str = 'AA.BB.CC:DD:EE:FF';
my $regex = qr/([A-Fa-f0-9]{2})([:\-\.]?)(?=[A-Fa-f0-9])/mp;
my $subst = '$1:';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";