$re = '/([A-Fa-f0-9]{2})([:\-\.]?)(?=[A-Fa-f0-9])/m';
$str = 'AA.BB.CC:DD:EE:FF';
$subst = "$1:";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;