using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Fa-f0-9]{2})([:\-\.]?)(?=[A-Fa-f0-9])";
string substitution = @"$1:";
string input = @"AA.BB.CC:DD:EE:FF";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}