#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "test_function\('[^'\\]*(?:\\.[^'\\]*)*'\s*,(true|false)"
Local $sString = "test_function('something',true);" & @CRLF & _
"//or" & @CRLF & _
"test_function('something',false);" & @CRLF & _
"//or" & @CRLF & _
"test_function('something',true,true);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")