using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"test_function\('[^'\\]*(?:\\.[^'\\]*)*'\s*,(true|false)";
string input = @"test_function('something',true);
//or
test_function('something',false);
//or
test_function('something',true,true);";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}