package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`test_function\('[^'\\]*(?:\\.[^'\\]*)*'\s*,(true|false)`)
var str = `test_function('something',true);
//or
test_function('something',false);
//or
test_function('something',true,true);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}