$re = '/test_function\(\'[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\'\s*,(true|false)/';
$str = 'test_function(\'something\',true);
//or
test_function(\'something\',false);
//or
test_function(\'something\',true,true);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);