using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([A-z*]+)-(?=[A-z*]+\b)";
string substitution = @"$1 ";
string input = @"Jean-Pierre bought ""blue-green-red"" product-2345 and other blue-red stuff.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}