const regex = /\b([A-z*]+)-(?=[A-z*]+\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([A-z*]+)-(?=[A-z*]+\\b)', 'gm')
const str = `Jean-Pierre bought "blue-green-red" product-2345 and other blue-red stuff.`;
const subst = `$1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);