re = /\b([A-z*]+)-(?=[A-z*]+\b)/m
str = 'Jean-Pierre bought "blue-green-red" product-2345 and other blue-red stuff.'
subst = '$1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result