use strict;
my $str = 'Jean-Pierre bought "blue-green-red" product-2345 and other blue-red stuff.';
my $regex = qr/\b([A-z*]+)-(?=[A-z*]+\b)/mp;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";