using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"GeSHi\s*([\w]+)";
string input = @"GeSHi hiii
GeSHi test
GeSHi elepjhant
GeSHi var1
GeSHi fun97
GeSHi abstarct
GeSHi String";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}