// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)GeSHi\s*([\w]+)").unwrap();
let string = "GeSHi hiii
GeSHi test
GeSHi elepjhant
GeSHi var1
GeSHi fun97
GeSHi abstarct
GeSHi String";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}