import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "GeSHi\\s*([\\w]+)";
final String string = "GeSHi hiii\n"
+ "GeSHi test\n"
+ "GeSHi elepjhant\n"
+ "GeSHi var1\n"
+ "GeSHi fun97\n"
+ "GeSHi abstarct\n"
+ "GeSHi String";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}