$re = '/GeSHi\s*([\w]+)/m';
$str = 'GeSHi hiii
GeSHi test
GeSHi elepjhant
GeSHi var1
GeSHi fun97
GeSHi abstarct
GeSHi String';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);