#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)^(?!(?:[^\n\p{Greek}]*\p{Greek}){3})[\p{Latin}\p{Hebrew}\p{Greek}]+$"
Local $sString = "A" & @CRLF & _
"b" & @CRLF & _
"β" & @CRLF & _
"aβ" & @CRLF & _
"aaaββג" & @CRLF & _
"aaaββגגג" & @CRLF & _
"aβaגβaגג" & @CRLF & _
"" & @CRLF & _
"aβaaβגβגג "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")