import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?:[^\\n\\p{Greek}]*\\p{Greek}){3})[\\p{Latin}\\p{Hebrew}\\p{Greek}]+$";
final String string = "A\n"
+ "b\n"
+ "β\n"
+ "aβ\n"
+ "aaaββג\n"
+ "aaaββגגג\n"
+ "aβaגβaגג\n\n"
+ "aβaaβגβגג ";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}