re = /^(?!(?:[^\n\p{Greek}]*\p{Greek}){3})[\p{Latin}\p{Hebrew}\p{Greek}]+$/m
str = 'A
b
β
aβ
aaaββג
aaaββגגג
aβaגβaגג
aβaaβגβגג '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end