using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(?:[^\n\p{Greek}]*\p{Greek}){3})[\p{Latin}\p{Hebrew}\p{Greek}]+$";
string input = @"A
b
β
aβ
aaaββג
aaaββגגג
aβaגβaגג
aβaaβגβגג ";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}