$re = '/^(?!(?:[^\n\p{Greek}]*\p{Greek}){3})[\p{Latin}\p{Hebrew}\p{Greek}]+$/um';
$str = 'A
b
β
aβ
aaaββג
aaaββגגג
aβaגβaגג
aβaaβגβגג ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);