const regex = /[2](?=[0-3])\dh|[0-1][0-9]h[0-5][0-9]min[0-5][0-9]s/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[2](?=[0-3])\\dh|[0-1][0-9]h[0-5][0-9]min[0-5][0-9]s', 'g')
const str = `19h32min16s
39h32min16s`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}