$re = '/[2](?=[0-3])\dh|[0-1][0-9]h[0-5][0-9]min[0-5][0-9]s/';
$str = '19h32min16s
39h32min16s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);