import re
regex = re.compile(r"[2](?=[0-3])\dh|[0-1][0-9]h[0-5][0-9]min[0-5][0-9]s")
test_str = ("19h32min16s\n"
"39h32min16s")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")