#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)\b(?i:т\.д|т\.п|др|г|чел|пр|см)\b\.?(*SKIP)(*FAIL)|\.\s*\w"
Local $sString = "Я охотник. Живу в лесу.И мне комфортно и т.п" & @CRLF & _
"См. тут. Я читал и др. произведения. В 2003 г. никто об этом не знал. И т.д. и т.п"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")