$re = '/\b(?i:т\.д|т\.п|др|г|чел|пр|см)\b\.?(*SKIP)(*FAIL)|\.\s*\w/u';
$str = 'Я охотник. Живу в лесу.И мне комфортно и т.п
См. тут. Я читал и др. произведения. В 2003 г. никто об этом не знал. И т.д. и т.п';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);