import re
regex = re.compile(r"\b(?i:т\.д|т\.п|др|г|чел|пр|см)\b\.?(*SKIP)(*FAIL)|\.\s*\w", flags=re.UNICODE)
test_str = ("Я охотник. Живу в лесу.И мне комфортно и т.п\n"
"См. тут. Я читал и др. произведения. В 2003 г. никто об этом не знал. И т.д. и т.п")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")