import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?i:т\\.д|т\\.п|др|г|чел|пр|см)\\b\\.?(*SKIP)(*FAIL)|\\.\\s*\\w";
final String string = "Я охотник. Живу в лесу.И мне комфортно и т.п\n"
+ "См. тут. Я читал и др. произведения. В 2003 г. никто об этом не знал. И т.д. и т.п";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}