// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)\b(?i:т\.д|т\.п|др|г|чел|пр|см)\b\.?(*SKIP)(*FAIL)|\.\s*\w").unwrap();
let string = "Я охотник. Живу в лесу.И мне комфортно и т.п
См. тут. Я читал и др. произведения. В 2003 г. никто об этом не знал. И т.д. и т.п";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}