using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^s3://([^/]+)/(.*)";
string input = @"s3://dev-datalake-cluster-bucket-q37evqefmksl/raw/wfm/users.11315";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}